Irregularities in email sending

Major incident Email campaigns
2023-01-05 13:54 CEST · 1 hour, 35 minutes

Updates

Resolved

We found the bug and deployed a fix. All pending campaigns are now successfully processed.

January 5, 2023 · 15:29 CEST
Investigating

We’re investigating an issue affecting a small number of email campaigns sent in the last few days.

January 5, 2023 · 13:57 CEST

← Back