Campaign send button disabled

Major incident Email campaigns
2023-03-13 15:35 CEST · 1 hour, 2 minutes

Updates

Resolved

Latest production update unexpectedly caused the issue, as soon as it was identified as the source it was reverted to restore functionality

March 13, 2023 · 16:37 CEST
Investigating

Currently being investigated

March 13, 2023 · 16:22 CEST

← Back