Sendgrid experiencing delays

Minor incident 3rd party services Sendgrid
2023-04-25 16:21 CEST · 1 hour, 49 minutes

Updates

Resolved

Multiple delays in email deliverability
Incident resolved
Our engineers have monitored the fix and confirmed the issue with delay in deliverability has been resolved. All services are now operating normally at this time.
Time posted
Apr 25, 09:03 PDT

April 25, 2023 · 18:10 CEST
Update

Monitoring
At 7:30 A.M. PT on April 25, 2023, our engineers identified and mitigated the issue that was causing delivery delays to some SendGrid customers and are currently monitoring traffic to ensure delivery. We will provide another update within an hour
Posted 1 minute ago. Apr 25, 2023 - 07:52 PDT

April 25, 2023 · 16:58 CEST
Monitoring

SOURCE - https://status.sendgrid.com/incidents/txnnvzm45qyd

Starting around 6:00 A.M. PT on April 25, 2023, our engineers began investigating an issue with email deliverability delays. Customers may experience delays in the deliverability for email API and marketing. We will provide another update in 1 hour or as soon as more information becomes available.
Posted 20 minutes ago. Apr 25, 2023 - 07:02 PDT

April 25, 2023 · 16:21 CEST

← Back