Campaign sending delay

Minor incident Email campaigns
2023-09-12 12:24 CEST · 51 minutes

Updates

Resolved

The incident has been resolved

September 12, 2023 · 13:15 CEST
Issue

We’re aware that some customers are facing delays in sending campaigns. Our team has identified the issue and is actively working on a resolution. Thank you for your understanding!

September 12, 2023 · 12:24 CEST

← Back