Newsrooms/Sites issues

Major incident Sites
2025-02-06 09:30 CET · 28 minutes

Updates

Resolved

We’ve rolled out a fix that brings back all sites/newsrooms.

February 6, 2025 · 09:57 CET
Issue

We are currently experiencing issues with sites/newsrooms. Investigation is ongoing

February 6, 2025 · 09:48 CET

← Back