Upload issues

Major incident Email campaigns 3rd party services Uploadcare
2025-10-20 10:26 CEST · 1 hour, 37 minutes

Updates

Update

Issue resolved? First signs of recovery, more information in on the Amazon Web Services status page.

We’re seeing customers back able to upload and edit images within Prezly. It’s too early to say all is good but we’re on the path towards resolution

October 20, 2025 · 11:32 CEST
Issue

We’re seeing an increase of file upload and download issues.

This is related to an incident at AWS (see status page) that routes/impacts a lot of internet traffic.

We’re working with our partners to find a solution

October 20, 2025 · 10:12 CEST

← Back