Increasing delay on sending email campaigns

Major incident Email campaigns
2020-10-06 10:55 CEST · 48 minutes

Updates

Resolved

Our engineering team has resolved the issue with increasing delay on sending email campaigns. We apologize for any inconvenience.

November 4, 2021 · 16:24 CEST
Monitoring

Our engineering team has identified the cause of the issue with increasing delay on sending email campaigns and already implemented a fix to resolve it.

November 4, 2021 · 16:24 CEST
Investigating

Our Engineering team is investigating an issue with increasing delay on sending email campaigns. We apologize for the inconvenience and will share an update once we have more information.

November 4, 2021 · 16:24 CEST

← Back