Statistics update delayed

Minor incident Email campaigns
2021-04-01 10:31 CEST · 20 minutes

Updates

Resolved

All the events are now processed.

November 4, 2021 · 16:25 CEST
Issue

We’re currently processing a high number of email campaign events which can cause a delay in updating statistics in our application interface. We apologize for the inconvenience this may cause.

November 4, 2021 · 16:25 CEST

← Back