Email campaign delays

Minor incident Email campaigns
2021-04-12 15:05 CEST · 33 minutes

Updates

Resolved

Our engineering team has resolved the issue.

November 4, 2021 · 16:25 CET
Monitoring

A small group of clients were affected by a temporary issue causing email campaigns delays between 15:05 and 15:38 CEST. The issue was meanwhile fixed. We apologize for the inconvenience!

November 4, 2021 · 16:25 CET

← Back