Campaign statistics delay

Minor incident Email campaigns
2021-09-13 13:06 CEST · 1 hour, 14 minutes, 31 seconds

Updates

Resolved

This issue has been resolved

September 13, 2021 · 14:20 CEST
Issue

We’re currently processing a high number of email campaign statistics. Some of the recently sent campaigns statistics reports could be delayed. We want to assure you that all campaigns were successfully delivered. Sorry for the inconvenience!

September 13, 2021 · 13:08 CEST

← Back