Email campaign sending delay

Minor incident Email campaigns
2022-02-15 11:51 CEST · 17 minutes

Updates

Resolved

The issue has been resolved.

February 15, 2022 · 12:08 CEST
Monitoring

We identified and fixed an issue causing delays in campaigns sending and we’re currently monitoring it. Sorry for the inconvenience!

February 15, 2022 · 11:55 CEST

← Back