Multiple accounts locked

Major incident Prezly App
2022-02-21 16:15 CEST · 6 minutes

Updates

Resolved

The issue has been resolved.

February 21, 2022 · 16:22 CEST
Issue

We’re investigating an issue causing multiple accounts lockout. Sorry for the inconvenience!

February 21, 2022 · 16:19 CEST

← Back