Email campaign sending delay

Minor incident Email campaigns
2022-05-16 10:49 · 58 minutes

Updates

Times are shown in Africa/Abidjan timezone
Resolved

The incident has been resolved

May 16, 2022 · 11:48
Issue

We’re currently processing a large volume of email campaigns and we’re noticing a delay in campaign sending process. We’re working to reduce this delay as much as possible.

May 16, 2022 · 10:55

← Back